Migration von PLESK, KK und ab geht’s

Gestern habe ich (mal wieder mit Onkel iKA zusammen) die Migration ans Laufen bekommen.

Eigentlich erklärt sich die Migration von PLESK ganz von alleine… eigentlich… WENN sie funktioniert. Der Fehler war, dank Google schnell gefunden und mit einem iKAfonat schnell behoben. Es war eine verbugte Version des openssh auf dem Quellsystems installiert. Nach einigem hin und her lief dann aber die Migration.

Um ca. 22h hieß es dann „Migration erfolgreich“. Auch ein TS ließ sich ohne zicken installieren. Dieser wir heute getestet… hoffentlich ist der stabiler als der bei einsblau…

Heute habe ich die Daten und die Datenbanken, PLESK Einstellungen und sonstiges geprüft, scheint alles suaber zu sein. Zwei Probleme gab es allerdings noch.

1. Der Apache wollte nicht starten… Fehler: certfile not found! Das freute mich allerdings, denn hier im neuen System funktionieren anscheinend die vhost.conf’s endlich. Also fix certfiles rüber geholt und der Apache startete auch. Wenn die Domains übertragen sind werd ich ja sehen ob er die geänderten certs übernimmt!

2. Bei Aufruf der IP im Browser öffnete er nicht die Standardseite, stattdessen sah man einige Fehlermeldungen von Joomla. Fehler: In der config von Joomla ist der absolute path angegeben. Der war beim SuSe System /srv/www/… und bei ubuntu ist es nun /var/www/… ! Also einfach die config geändert und nun läuft es auch!

Schlußendlich hab ich den Apache nun abgeschaltet, bis die Domains übertragen sind, einsblau angerufen und von KK informiert und bei hosteurope Domaiübernahme über’s KIS beantragt.

Sobald die Domains auf meine neue IP verweisen/verlinkt sind kopiere ich noch mal die veränderten DB’s und Daten, nehme den neuen Apache in Betrieb, klemme den alten ab und dann ist Testen angesagt! Wenn alles gut läuft, war der Login zum Abschalten des Apache’s mein letzter bei einsblau!

Danke nochmal an iKA für die Hilfe mit dem SSH! Danke an einsblau FÜR VERDAMMT GARNIX!!

Ein Gedanke zu „Migration von PLESK, KK und ab geht’s

  1. iKArus

    Gern geschehen, wenn es auch etwas schneller gegangen wäre, wenn Du gleich den 64’er genommen hättest. :mrgreen:

    PS. Wenn Du den Server bei 1blau noch länger genutzt hättest, hätte ich mir den mal genauer schauen müssen, denn es ist schon merkwürdig, dass 1blu teilweise veraltete Quellen anbietet …

    Egal, Hauptsache es läuft jetzt alles. 🙂

Kommentar verfassen