Schlagwort-Archive: installieren

Bisher gelöste Probleme mit OS X LION

Lion auf dem Mac ersetzt die Katze im Toaster… Nein Quark, eigentlich läuft Lion extrem super, mein Mac Mini 2GHz ist gefühlt sogar schneller geworden. Ich fühle mich als iOS PowerUser extrem heimisch und einige kleine Anfangsprobleme wurden beinahe alle behoben.

Ich habe hier im Haus 2 Macs, ein Mini als Server und ein MBP als Arbeitsgerät. Gerät und Lösung stehen jeweils hinter dem Problem.

  • SwitchResX wollte nicht mehr. (Mini, Update)
  • easyVPN killte alle connections. (Mini, Update)
  • Drobo Dashboard wollte nichts mehr anzeigen. (Mini, Update)
  • Air Mouse Server verweigerte Connections. (Mini, Update)
  • Meine BT Headphones liefen nicht mehr unter Plex. (Beide, neues Midi Audio Gerät erstellen)
  • jdownloader brauchte die neue Java Runtime (Mini, installieren)
  • Little Snitch verweigerte den Dienst. (Beide, Update)
  • Visor funktioniert nicht mehr. (MBP, heißt jetzt Total Terminal und geht wieder)
  • TinkerTool zeigte nichts mehr an außer Schriften. (Beide, Update)
  • 3 Finger zurück funktionierte nicht in Chrome und 2 Finger wischen ebenfalls nicht. Also, den Wechsel der Apps auf 4 Finger umstellen und für vor/zurück wieder 3finger swipe.

VPN auf Snow Leopard vs. MobileMe

Srsly Apple… what the fuck??

Ich habe nun einige Tage versucht ein L2TP VPN einzurichten… Ging nicht… Und warum? Da MobileMe meint, Port 4500 nutzt ja kein anderer…

Bei mir steht ein Mac daheim, welcher die täglichen Sklavenarbeiten erledigt und als Media Center dient. Darauf läuft ein normales Snow Leopard. Wegen „Back to my Mac“ habe ich meinen MobileMe Account auch in Airport Extreme und Mac Mini eingetragen, tatsächlich habe ich es nie benutzt. Meine Daten hatte ich immer dabei und Screensharing lief über VNC mit dynDNS, besonders weil ich es auch vom iPhone/iPad nutzen wollte. Und jetzt, da VPN läuft, komme ich trotzdem an meine Daten!

Vorab ein Text aus dem Apple FAQ:
If you wish to enable NAT port forwarding to L2TP VPN servers at private addresses on your AirPort Extreme or Time Capsule network, first ensure that MobileMe is disabled in AirPort Utility. If you configure NAT port forwarding to L2TP VPN servers at private addresses with MobileMe enabled, the setting for port forwarding to the servers will be ignored.

Hier mal eine kleine Anleitung: Weiterlesen

Umstieg auf Vista 64bit

Ich hau mal zuerst mein Fazit raus: Umsteigen auf Vista 32bit lohnt aus meiner Sicht eher nicht, Vista 64bit hat mich allerdings überzeugt… auch wenn ich dieses OS noch vor einer Woche verteufelt habe!

Warum ich umgestiegen bin? Hmmm, wohl Neugier und auch ein wenig Wahnsinn? Naja, viele meiner Freunde und Bekannten waren von Vista64 sehr überzeugt, ich als Supporter fand das System grausam… Aber als privater Anwender macht es mir richtig spass damit zu werkeln.

Treiber und Anwedungsprobleme hatte ich absolut keine, Spiele laden schneller und auch Photoshop macht mir die großen PSD’s merklich schneller auf. Klar, ich musste auf 4GB RAM upgraden, aber die 2GB zusätzlich bekommt man echt hinterher geworfen im Moment!

Hier und da hakt die Performance bei Spielen allerdings noch, das liegt aber vor allem an den Grafikkartentreibern und die sollen demnächst wieder ein Update erfahren. Es nervt auch, immer alles 2-3 mal bestätigen zu müssen, aber da gewöhnt man sich schnell dran. Vista soll in der 64bit Version außerdem über erweiterten Kernel-Schutz verfügen. Gut, die Installation samt SP1 und Patches dauert halt, aber das kennt man a schon von XP… Nun, nach einigen Stunden, eingriffen ins System, killen von Diensten, umstellen der Oberfläche und Installation der Programme die ich so nutze, etc. ist alles fertig und ich kann genau so weitermachen wie unter XP nur halt schneller und mit DX10! Ich gebe sogar zu, das ich mich sicherer fühle und stabiler scheint das System auch zu sein…

Ich werde jetzt erstmal ein paar Wochen testen und dann sehen, was sich noch so ergibt!

Call of Duty 4 Server auf VPS

Oh man… viele Leute in Foren schreiben, das ein VPS vollkommen ungeeignet sei, um einen CoD4 Server zum Laufen zu bringen. Das sind wohl die Leute, die es nie versucht haben!

Ich für meinen Teil habe einen VPS mit 512mb RAM und ubuntu bei hosteurope und da läuft seit gestern ein CoD4 dedicated Server, der keine 200mb RAM frisst, nen Ping von 19-32 liefert und 12 Slots hat.

Die ca. 6GB ließen sich in einer Nacht ohne Probleme ins httpdocs verschieben und per console in ein Verzeichnis unter /home. Der User ist wie bem Teamspeak ein eingeschränktes Konto. Traffic verursacht so ein CoD4 Server selbst bei 10/12 Slots nicht!

Momentan läuft er mit einer Public config im unranked Modus. Morgen werde ich mit einem Kumpel zusammen PAM4 installieren und eine ordentliche config erstellen, so das man ihn für Wars und Fun-Wars nutzen kann.

Einen Guide schreibe ich vielleicht auch noch, denn ich musste mir das ganze aus 4 Guides zusammenkleben… Der Server ist nicht öffentlich, aber wer hier regelmäßig liest, darf sich dort gerne mal von mir abknallen lassen 😉

Über CoD4 kann ich nur sagen: IMBA Game, der totale Hammer, nur Public Server sind total ätzend zum Zocken.

Migration von PLESK, KK und ab geht’s

Gestern habe ich (mal wieder mit Onkel iKA zusammen) die Migration ans Laufen bekommen.

Eigentlich erklärt sich die Migration von PLESK ganz von alleine… eigentlich… WENN sie funktioniert. Der Fehler war, dank Google schnell gefunden und mit einem iKAfonat schnell behoben. Es war eine verbugte Version des openssh auf dem Quellsystems installiert. Nach einigem hin und her lief dann aber die Migration.

Um ca. 22h hieß es dann „Migration erfolgreich“. Auch ein TS ließ sich ohne zicken installieren. Dieser wir heute getestet… hoffentlich ist der stabiler als der bei einsblau…

Heute habe ich die Daten und die Datenbanken, PLESK Einstellungen und sonstiges geprüft, scheint alles suaber zu sein. Zwei Probleme gab es allerdings noch.

1. Der Apache wollte nicht starten… Fehler: certfile not found! Das freute mich allerdings, denn hier im neuen System funktionieren anscheinend die vhost.conf’s endlich. Also fix certfiles rüber geholt und der Apache startete auch. Wenn die Domains übertragen sind werd ich ja sehen ob er die geänderten certs übernimmt!

2. Bei Aufruf der IP im Browser öffnete er nicht die Standardseite, stattdessen sah man einige Fehlermeldungen von Joomla. Fehler: In der config von Joomla ist der absolute path angegeben. Der war beim SuSe System /srv/www/… und bei ubuntu ist es nun /var/www/… ! Also einfach die config geändert und nun läuft es auch!

Schlußendlich hab ich den Apache nun abgeschaltet, bis die Domains übertragen sind, einsblau angerufen und von KK informiert und bei hosteurope Domaiübernahme über’s KIS beantragt.

Sobald die Domains auf meine neue IP verweisen/verlinkt sind kopiere ich noch mal die veränderten DB’s und Daten, nehme den neuen Apache in Betrieb, klemme den alten ab und dann ist Testen angesagt! Wenn alles gut läuft, war der Login zum Abschalten des Apache’s mein letzter bei einsblau!

Danke nochmal an iKA für die Hilfe mit dem SSH! Danke an einsblau FÜR VERDAMMT GARNIX!!